Tagged: 

This topic contains 7 replies, has 4 voices, and was last updated by  Aya Ali 2 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2152

    sosotura
    Participant

    Is there any way to do this? Seems that elementor tab widget only supports text editor as content. I want to display different carousel elements in each tabs respectively. Any ideas?

    #2153

    Abanob
    Keymaster

    Hello sosotura,

    Hope you’re having a great day!

    Actually, integrating Premium Carousel widget with Elementor tabs widget can be implemented only using Elementor Pro, you can create an Elementor template, use the shortcode that Elementor Pro provides for your template in the text editor of the Tabs widget, Please check the attached screenshots for more clarification.

    Elementor Templates Shortcodes
    Carousel Template within Tabs Widget

    If you have any questions, please feed me back.

    Thanks,
    Abanob

    • This reply was modified 1 year, 2 months ago by  Abanob.
    #2157

    sosotura
    Participant

    Thanks for detailed answers. So I’ve put several unique shortcodes (which are shown in elementor template) and it’s roughly working, but now another problems occur:

    1. Every premium carousel(with autoplay on, transition 1500ms) in tabs seems to work completely / respectively even when not displayed, since every slick-slider setting(for each tabs) maybe on slick-initialized. According to this link, destroying slick function can be an way to go, so I added this jquery code to remove “slick-initialized” class when elementor tab is not active but it’s not working as intended. Any ideas?

    jQuery(document).ready(function($) {
    var $tab-content = $(“.elementor-tab-content”);
    if ($tab-content.hasClass(“elementor-active”)) {
    // if tab-content div has elementor-active class, nothing to execute.
    } else {
    $tab-content.find(“.slick-slider”).removeClass(“slick-initialized”);
    // if this hasn’t class, find slick-slider class in grandchild div and remove or unlick initialize function. but both removeclass.() and unslick() don’t work.
    }
    });

    2. Loading background-image with carousel seems to be delayed to load when autoplay & transition feature is on. It’s hard to describe so I’ve attached img. But not sure it’s regarding autoplay feature as mentioned at 1.

    Please see this image (imgur)

    Also you can see my test page at https://sosotura.2ix.de/ see the middle of page there’s tab section.

    #2177

    Abanob
    Keymaster

    Hello sosotura,

    Sorry for being late for reply.

    Actually, the Premium Carousel widget code building structure is pretty complicated, I can see the issue but I need to farther check but I will need an access credentials. If you don’t mind you can send them privately on a pm through our forums.
    Leap13 Forums

    Have a great day!!

    Thanks,
    Abanob

    #38487

    aaronestepa
    Participant

    Was there a solution to this? I appear to be having the same issue.

    #38540

    Aya Ali
    Participant

    Hello aaron,
    Hope you’re doing well today 🙂
    Well, may I ask you to send a link for your post/page with the carousel element ? so that I can check this from my end.
    Thanks
    Aya

    #38870

    aaronestepa
    Participant

    Here is the page with the issue. Thanks for taking a look.

    Deli, Cheese, & Bakery

    #39084

    Aya Ali
    Participant

    Hi Aaron,
    Hope you’re doing well today 🙂
    I couldn’t regenerate the issue on my side, so I would be glad to check this farther from your end, but I will need an admin access credentials, so may I ask you to submit a ticket on our support ticket system ? so that I can check this from your end.
    Thanks
    Aya

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.