Hi Ricdam,

Thank you for your words! We appreciate it 🙂

Concerning premium blog widget, it seems that you didn’t add any posts yet. All you have to do is go to Dashboard > Posts > Add New. You have to include a title, content, category, and a featured image for each post you add. After that, go to premium blog widget > content settings > categories > then select the categories which you want to show in your page.

Please let us know if you have any further questions.

Kindest Regards,